Posted on

New update and e-mail settings

Well, it’s been a while, but every things been working fine and dandy, but e-mail has never been able to send from the site, so I decided to update to the latest version and check my e-mail settings.

Updating to the new version was as simple as ever! First, use Go Daddy’s admin website to backup the MSSQL Database, then FTP the site back to my workstation for a backup. Then download the new version of mojoPortal for .NET 3.5 and unzip it!

Now I opened the user.config.sample file and added all the settings in my user.config file from my backup, plus added the following lines for e-mail support on Go Daddy hosting:

<add key="SMTPServer" value="relay-hosting.secureserver.net" />
<add key="SMTPRequiresAuthentication" value="false" />
<add key="SMTPUseSsl" value="false" />
<add key="SMTPPort" value="25" />
<add key="SMTPUser" value="" />
<add key="SMTPPassword" value="" />

Now save this as user.config and that’s that file done! Open the Web.config file, and here, you’ll notice the medium trust has become default now, not full trust, so you no longer have to do any renaming of files, just change the mailSettings below for mail to work with Go Daddy:

  <system.net>
    <mailSettings>
       <smtp from="noreply@domain.com">
           <network host="relay-hosting.secureserver.net" port="25" />
       </smtp>
    </mailSettings>
  </system.net>

Save the file again, then ftp the new mojoPortal installation over the top of the old installation, then run the /Setup scripts to get the new site up and running!

When you are using the Contact web feature you must change the settings to NOT send at the e-mail address entered and to send from an address @domain.com rather than any gmail or hotmail account, as the Go Daddy SMTP relay server will not relay messages with @gmail.com, @yahoo.com, @hotmail.com, etc… So if you leave that option ticked, you will never receive e-mails from people that enter addresses like that in the From box.

I’m going to be looking at the jQuery used in mojoPortal next and figure out why some themes seem to work great on iPad and some don’t! I’ve also been told there is a problem with the editor on iPad, so I’ll be investigating that next, so if this is also a problem for you, hang tight and I’ll see what I can do!

Leave a Reply

Your email address will not be published. Required fields are marked *